Ride Report.

Post Reply
Cster
Posts: 117
Joined: Fri Mar 20, 2020 7:44 pm

Ride Report.

Post by Cster »

I got out and rode yesterday, lovely feeling of just being out on a bike. Ran the Tank. Feeling better now. Spoke to no-one but I do believe I will need to go fill up for the next one.
olfrt
Posts: 80
Joined: Sun Feb 09, 2020 3:50 pm
Location: Rochester Vic

Re: Ride Report.

Post by olfrt »

I did a quick 'recce' run to our next Branch ride destination on Sunday. Then they closed everything down, I only had a quick (almost) run through the museum cos I knew I was going back. Now I have to wait. :(
Paul Butler #17758
Cster
Posts: 117
Joined: Fri Mar 20, 2020 7:44 pm

Re: Ride Report.

Post by Cster »

Ah which one was that mate Deni or Echuca?
I ducked out to the freeway up at Lochinvar and did the run to the Bluegums exit and then out and round the Lakes way so as to come back home form the otherway. Need to do another one now.
Cster
Posts: 117
Joined: Fri Mar 20, 2020 7:44 pm

Re: Ride Report.

Post by Cster »

There is no ride report for today, It Rained and I'd just Electro-Luxed the Comfort Seat so I wasn't getting it wet.
Ken
Posts: 148
Joined: Sat Feb 08, 2020 9:38 am
Location: Adelaide

Re: Ride Report.

Post by Ken »

Here is one with pictures and map: https://ulyssesadelaide.com.au/piwigo/i ... tegory/453
(Adelaide Branch Sunday ride 12/7/20.)
Ken Wagnitz #21315
Cster
Posts: 117
Joined: Fri Mar 20, 2020 7:44 pm

Re: Ride Report.

Post by Cster »

Wow 29 photo's, you certainly managed to take a lot of them. Looked like a good outing
Post Reply